I - INTRODUCCIÓN


I.1 - Objetivos

En muchos tipos de actividades, como la cobranza, es necesario planear, organizar y supervisar el trabajo de los colaboradores y controlar el dinero, lo que implica coordinar y supervisar cientos de asuntos cada día. Usualmente estas actividades requieren imprimir documentos, formatos, enviar correos electrónicos y hacer telefonemas, labores que una computadora puede automatizar. El objetivo de este sistema computarizado es automatizar el registro, actualización y administración de las actividades y movimientos de dinero, así como la impresión de documentos, formatos, envíos de correo electrónico y telefonemas.

El sistema registra cada una de las actividades usuales en forma automática. Para ello se diseñan Procedimientos, que son el conjunto de acciones usuales para cada deudor; cuando se registra un nuevo deudor, se elige el procedimiento aplicable a él, y automáticamente se generan en la computadora todas las actividades incluidas en ese procedimiento, con las fechas adecuadas y asignadas a los responsables de cada tipo de actividad, que son llamadas Acciones, para distinguirlas de la clase genérica, que se llama; Actividad. También podrá modificar y eliminarlas, así como agregar nuevas.

Actividades

Los responsables de realizar las actividades pueden ver en su computadora las actividades que le corresponden e imprimir un calendario de actividades, modificar los datos, anotar sus observaciones, reportar la ejecución o suspensión de cada una de ellas, así como registrar los gastos realizados y los pagos que han hecho los deudores.

De esta forma se obtiene una información completa y actualizada de las actividades de todos, lo que permite la administración de las mismas, incluyendo:

· Planear las carga de trabajo de cada uno de sus colaboradores, modificando las fechas de responsables de las actividades planeadas o reasignando a otros colaboradores.

· Organizar el trabajo de cada colaborador, con un calendario de actividades.

· Supervisar el trabajo realizado por cada uno de sus colaboradores, con diversos reportes detallados y estadísticos.

Pagos, Gastos y Comisiones

Al realizar la cobranza, se registran los pagos de los deudores, así como los gastos que se realizan y las comisiones que se cobran a los clientes. Con esta información puede supervisar y contabilizar pagos, gastos y comisiones con diversos reportes que le permiten controlar el dinero y valorar los costos.

Documentos

La mayoría de los documentos, formatos, correos electrónicos, etc. que usa la empresa puede automatizarse. Por ejemplo, para documentos en Word, se diseñan con el texto fijo que lleva dicho documento y el formato deseado, indicando donde se insertan los datos específicos de cada deudor, cliente, etc. Los usuarios podrán imprimir automáticamente el documento, donde se insertan los datos específicos del deudor, cliente, etc.

Similarmente, puede automatizar la impresión de formatos preimpresos, correos electrónicos y telefonemas.


I.2 - Implementación

Cada empresa realiza su cobranza con un método diferente, que ha diseñado conforme a sus necesidades. El Sistema está diseñado para que pueda configurarlo según sus necesidades, y para ello deberá indicarle que actividades usuales se realizan, que documentos utiliza, quienes son sus clientes y los colaboradores, etc.

Inicialmente se planea como automatizar el trabajo administrativo con el sistema, y para ello se debe registrar la siguiente información:

· Clientes y colaboradores: Se registra los datos de los clientes y los colaboradores

· Procedimientos: Analizando las actividades de la empresa, se definen los conjuntos de acciones sistemáticas que se realizan para cada deudor; y con ello se forma un Procedimiento. Cuando se captura a un nuevo deudor, se decide el procedimiento que debe aplicarse con él, y las actividades incluidas en este procedimiento se generan automáticamente para ese deudor.

· Documentos, formatos, correos electrónicos: En cada procedimiento se decide que documentos, formatos preimpresos, correos, etc. se utilizan habitualmente, diseñándolos. Por ejemplo, un documento de Word, se diseña con el texto fijo y formato necesario.

· Actividades: Se registran las actividades individuales que forman cada procedimiento, identificando los documentos que usa cada actividad y el responsable usual de esta actividad.

Con esta información, el sistema se configura para automatizar las actividades en la forma que conviene en la empresa.

Instalación

Instala el sistema en cada computadora, como lo indica el inciso I.5. Para instalar el sistema en una red de computadoras, se decide cuál de las computadoras contendrá la base datos; es usual elegir a la mejor disponible para ello.

Una vez configurado el sistema, puede iniciarse el uso cotidiano, donde se registran, modifican y consultan la información de:

· Actividades a realizar por cada colaborador

· Impresión de documentos, formatos, el envío de correos electrónicos, etc.

· Deudores: registrar los nuevos, modificar los datos que han cambiado.

· Movimientos de dinero: pagos, gastos, comisiones

Periódicamente requiere administrar las actividades, usando la modificación y los Reportes detallados y estadísticos de:

· Actividades: revisar las actividades programadas, realizadas, suspendidas y atrasadas; las de cada deudor, cada colaborador, etc.

· Colaboradores: actividades pendientes, atrasadas, programadas.

· Gastos: de cada colaborador, según su tipo, según la fecha, etc.

· Pagos: de cada deudor, para cada cliente, por cada colaborador, etc.

· Comisiones: cuales debe cobrar, cuanto le ha pagado cada cliente. etc.


I.5 - Licencia

Sistema desarrollado por SACSA. La versión demostrativa que obtiene en www.software-sacsa.com tiene limitaciones: no puede registrar nuevos deudores, responsables ni clientes y funciona durante 30 días, para que pueda revisar su funcionalidad.

Si desea consultar temas específicos, podemos atenderle por 3 medios:

  • Conferencia por internet. Requiere una PC conectada a Internet por cualquier medio y hacer una cita.
  • Telefónos: 52(55) 5234-0015 y 52(55)5348-3913
  • Correo electrónico: ventas@software-sacsa.com

Si le interesa adquirirlo, pida la versión completa. Tendrá asesoría para instalar y operar el sistema, así como configurarlo conforme sus necesidades.


I.3 – Base de Datos

Toda la información que se registra en el sistema se deposita en la base datos, por lo que es imprescindible que se proteja esta información.

La base datos está organizada en tablas, que almacenan la información en sus campos. Por ejemplo, la tabla Deudores tiene campos para: Deudor (Razón social del deudor), Contacto (Nombre de la persona que representa al deudor), Cliente (Quien nos encargo la cobranza), etc. Algunos campos indican una relación con otras tablas, por ejemplo: el campo Cliente permite identificar al Cliente que encargo la cobranza de ese Deudor; éste dato no es información del cliente, sino es el número que el Cliente referido tiene en su campo: Clave; de esta forma se pueden obtener los datos del cliente para cada deudor.

Cada tabla se presenta con la lista de sus campos, y las relaciones se indican con las líneas que unen las tablas.


I.4 – Requisitos de Hardware

El Sistema COBRANZA puede operar en Computadoras PC compatibles con sistema Operativo Windows de 32 bits: Win95, Win98, WinNT, Win 2000 y WinXP, con memoria RAM mínima de 64 Mb y monitor VGA ó superior. Ocupa en su disco duro 7.5 Mb., más el espacio que ocupe la Base de Datos. El Sistema registra la información en una Base de Datos, con máquina Jet 3.5 compatible con Access de Microsoft.

II – FUNCIONES DEL SISTEMA

El Sistema Cobranza tiene como objetivo automatizar la operación de una agencia de cobranza, registrando el avance de sus actividades, automatizando los documentos, formatos, fax, correos electrónicos y telefonemas que se requieren para la cobranza a los deudores. También registra los pagos, gastos y comisiones. Con ello se tiene una información detallada de la operación de cobranza, que se emplea para planear, coordinar, ejecutar y supervisar las actividades, así como contabilizar los ingresos y egresos, Las funciones del sistema se eligen por medio del Menú, que se describe a continuación:


II.1 – A C C I O N E S

Este grupo de funciones permite manejar la información sobre las acciones de cobranza: registrarlas, modificarlas, eliminarlas y consultar las con diversos criterios, así como obtener estadísticas de la actividad realizada por cada deudor, a cargo de cada responsable, etc.


II.1.1 - Actualizar

Esta pantalla le permita revisar simultáneamente la información de clientes, los deudores que cada cliente y las acciones de cobranza planeadas y realizadas para cada deudor. Para ello, presenta tres Listas: Clientes, Deudores y Acciones para Deudores, que están ligadas; es decir: tocando un cliente presenta a los deudores de ese cliente, y luego, tocando un Deudor, presenta las acciones de cobranza para él.

Al tocar cualquier elemento de las listas, podrá ver en el cuadro de texto inferior la información sobre ese elemento.

Además de la revisión, puede también agregar nuevos clientes, deudores y acciones, modificar los existentes y eliminarlos; para ello señale la lista deseada, usando toque derecho del ratón (señala un elemento de la Lista con el cursor y oprime el botón derecho del ratón) y aparecen las siguientes opciones:

[Agrega] un nuevo cliente, deudor o actividad, según la lista que haya tocado.

[Modifica] un cliente, deudor o acciones, según la lista que haya tocado. También puede eliminarlo.

[Tabla] presenta una tabla de clientes, deudores o acciones, con datos completos y las posibilidades de imprimir un reporte, escoger u ordenar.

[Buscar] al cliente, deudor o actividad, usando alguna parte de su nombre.

[Nada] no hace nada.

Para finalizar, toque le tecla [Termina]


II.1.2 – Consultas

Las consultas de acciones le permiten obtener información que necesite, bien sea en la pantalla ó en Reportes impresos, así como seleccionar y ordenar la información.

Dispone de diversas opciones:

· Acciones con Deudores de cada Cliente

· Acciones para cada Deudor

· Acciones por cada Procedimientos

· Acciones de cada Responsable

La información se presenta en forma Tabular, con una fila para cada Acción, y en cada columna sus datos. Puede señalar una fila, tocándola con ratón; moverla con las teclas de [flecha arriba-abajo], [AvPag] y [RePag].

Si las filas exceden la ventana, aparece una banda horizontal con cursor que permite mover las filas, tocando la banda o arrastrando el cursor. Si las columnas exceden la ventana, aparece una banda vertical con cursor que permite mover las filas, tocando la banda o arrastrando el cursor.

Las teclas inferiores sirven para:

[Selecciona]: puede utilizar cualquier dato de la acción para escoger sólo los que necesitará. Por ejemplo, usando el dato de estado, puede verse sólo las acciones planeadas, que con las realizadas por la suspendida; usando el dato responsable, se puede ver las secciones encargadas a cada auxiliar. Ver explicación detallada en {III.131}.

[Ordena] puede dar la secuencia que le sea más útil para ver la información. Por ejemplo, al revisarlas acciones para un deudor específico, puede ordenarlas por fecha, para tener una idea del proceso que ha seguido el caso de ese deudor. Ver explicación detallada en {III.132}.

[Original] regresa a la información original, después de usar Selección u Ordenación, que la cambio.

[Imprime] Imprimir ó exportar la información presentada en la tabla. Ver explicación detallada en {III.23}.


II.1.2.1 - Consulta General

La consulta general presenta una tabla con todas las acciones, y le permite obtener la información que necesita, usando la selección y ordenación.


II.1.2.2 – Cliente

Permite revisar las acciones que se han realizado con los Deudores de cada Cliente, para poder informar de a sus clientes el avance del proceso de cobranza encargando.

Primero aparece una ventana pidiéndole que elija un Cliente, y se debe hacer con un doble toque sobre el nombre del Cliente.

Una vez seleccionado el Cliente, aparecerán los informes que pertenecen a ese Cliente.


II.1.2.3 – Deudor

Frecuentemente se requiere revisar, para cada deudor en particular, como ha avanzado el proceso de cobranza.

Primero aparece una ventana pidiéndole que elija un Deudor, y se debe hacer con un doble toque sobre el nombre del Deudor.

Posteriormente se visualizaran las acciones que se refieren a ese Deudor.


II.1.2.4 – Procedimiento

Con objeto de conocer el grado de avance de las acciones, puede convenir revisarlas según el tipo de Procedimiento, ya que de esta manera se visualizan los procedimientos que tienen problemas y aquellos que han avanzado adecuadamente, permitiendo identificar los ‘cuellos de botella’ del proceso de cobranza.

Se pide que se seleccione uno de los Procedimientos que aparecen en pantalla, con doble toque sobre el.

Después aparecen las acciones que pertenecen al tipo de procedimiento que seleccionamos anteriormente.


II.1.2.5 – Actividad

Esta función revisa las acciones de un tipo específico, para lo cual inicialmente elige una Actividad, y luego presenta las acciones para deudores de esa clase.


II.1.2.6 – Responsable

Esta función tiene como objetivo facilitar la organización y supervisión del proceso de cobranza. Para ello organiza la información de la cobranza en función de los responsables de las acciones a realizar, permitiéndoles:

· Dar a cada responsable de las acciones un programa calendarizado, obtenido seleccionando las acciones que dependen de ese responsable y cuyo estado es planeado.

· Revisar el avance de las acciones encargadas a cada responsable, seleccionando las acciones que dependen de cada responsable, con estado realizado.

Inicialmente se pide que ingrese un periodo de fechas, para presentar en la tabla solo aquellas cuyo inicio es posterior o cuyo termino es anterior al periodo definido. Se pregunta la fecha máxima y mínima que debe considerarse.

Posteriormente aparecerá una ventana en la cual se le pedirá que seleccione un Responsable de la lista, haciendo doble toque sobre su nombre para que aparezcan las acciones que corresponden a ese Responsable.


II.1.2.7 – Acciones Atrasadas

Para conocer que acciones planeadas no han sido realizadas a tiempo, se pide la fecha de comparación, para presentar las acciones que están planeadas para esa fecha o anterior, y aún no han sido hechas, por lo que están en estado “Planeada”.


II.1.3 Estadísticas

Estos resúmenes estadísticos {III.41} de la acciones de cobranza, permiten revisar rápidamente la cantidad de acciones realizadas, suspendidas y planeadas por deudor, procedimiento y responsable.

Para mover las Filas use [Flecha Arriba-Abajo] ó toque con el ratón la banda del extremo derecho, y con las teclas inferiores, tiene:

[Imprime] | Imprimir ó exportar la Tabla, incluso las filas y columnas no visibles en la pantalla
[Gráfica] | Presenta en la pantalla la Gráfica correspondiente a la Tabla Estadística
[Termina] | Regresar al Menú

Si usa [Gráfica], produce una Gráfica Estadística con los Datos de la Tabla. La Gráfica se presenta a color en la pantalla y puede elegir entre las opciones:

[Estilo] | La Gráfica se presenta en ocho estilos diferentes, 4 de dos dimensiones y 4 de tres dimensiones, que puede elegir en una Lista de Estilos.
[Impresión] | Si es impresora de color, se reproduce la Gráfica a colores; pero si no, cada color se convertirá en un tono de gris, para poder ser impresa en blanco y negro.
[Título] | Puede modificar el título de la Gráfica, que originalmente es el mismo del Resumen Estadístico, para explicar con precisión su significado


II.1.3.1 - Deudor

Para estimar cual es el avance de Acciones, se presenta en la tabla una fila para cada deudor y procedimiento, de forma que pueden aparecer varias filas para un deudor, para cada tipo de procedimiento.

Las últimas columnas de la fila, informa la cantidad de acciones planeadas, realizadas sin suspendidas.


II.1.3.2 - Procedimiento

Para valorar el trabajo realizado, y detectar los ‘cuellos de botella’ en los diferentes procedimientos empleados en la cobranza, se usa este resumen estadístico. Inicialmente pide la fecha inicial, y a partir de esta fecha hasta el momento actual se realizará la estadística de acciones.

Presenta una tabla en la que destina una fila a cada procedimiento típico, y en las columnas subsiguientes presenta el número de acciones planeadas, realizadas sin suspendidas de este tipo de acción.


II.1.3.3 - Responsable

Con la finalidad de revisar el avance de trabajo para cada responsable, se pide una fecha inicial para considerar las acciones realizadas desde esa fecha inicial hasta el momento. Revisando las acciones y agrupándolas por responsable, se presenta una tabla con una fila para cada responsable, cuyas columnas presentan el número de acciones que ha realizado, que ha suspendido o que se mantienen planeadas.


II.1.3.4 – Actividad

Para estimar los volúmenes de trabajo realizado y pendiente, según su clase, se revisan las acciones organizadas por su clase, es decir, Actividad correspondiente, en el período de fechas deseado.


II.1.3.5 – Cliente

Frecuentemente tendrá que revisar el trabajo de cobranza realizado para cada uno de sus clientes, para lo que la estadística de acciones planeadas y realizadas en un período, puede serle útil.


II.1.4 – Ejecutar

El sistema le permite automatizar muchos de los trabajos cotidianos de una agencia de cobranza, como emitir documentos y formatos, para la gestión y tramitación de la cobranza, avisos y recordatorios a los deudores por teléfono y correo electrónico y organizar visitas imprimiendo los datos de cada deudor. Este conjunto de funciones ejecutan automáticamente las acciones programadas que están pendientes (Estado = ‘Planeada’).

Para este efecto, inicialmente define un período de fechas para presentar las acciones programadas en ese periodo, aun sin realizar, (estado = 'Planeada'). En la ventana tabular puede preseleccionar el trabajo que desea realizar, es decir, elegir solamente una parte es estos. Para ello, usar Selecciona {III.131} que le permite escoger los trabajos que desea realizar según el contenido de cualquiera de los datos.

A continuación se le presenta otra pantalla tabular con los trabajos preseleccionados, para que pueda decidir individualmente si los realiza, pues en ocasiones necesitará suspender alguno. Revise los trabajos planeados para decidir si desea que algunos de ellos no se hagan. La primera columna de cada fila se reserva para indicar la autorización para ejecutar ese trabajo, y tocando la fila con el ratón cambia la autorización. De esta manera puede hacer excepciones individuales, y también puede autorizar a todos usando la tecla [Todos Sí] o desautorizar a todos con la tecla [Todos No].

Cuando ya esté definido cuales se harán y cuáles no, use la tecla [Ejecuta] para realizarlos. En los incisos siguientes se describe la ejecución de los diversos trabajos automatizados, según su tipo.

Al finalizar la ejecución de los trabajos es necesario actualizar el estado de su realización, que era: 'Planeado' y cambiarlo a 'Realizado' si así conviene.

Para ello se presentan en formato tabular los trabajos supuestamente realizados, indicando en la 1° columna = Si, que fue realizado. Puede cambiar el estado en forma individual, tocando con el ratón la fila correspondiente, si ese trabajo en particular no se realizó, o bien utilizar las teclas de la parte inferior para cambiar todos los trabajos: Si = si realizado.


II.1.4.1 - Documentos de Word

Se presentan las acciones planeadas que sean del tipo Documento, para generar automáticamente los documentos, insertando en el texto fijo los datos individuales correspondientes. El sistema controla directamente el programa Word, por lo que no debe interferirse; esto significa que no debe tener abierto Word cuando use esta función, ni cerrarlo mientras este ejecutando esta función.

Puede proceder en formas diversas, según lo requiera:

Sólo generarlos

Esta opción le sirve para modificar el documento, agregando ó quitando texto según el caso, y luego imprimirlo ó grabarlo. Como el sistema controla directamente el programa Word, no debe cerrar Word mientras este ejecutando esta función. Si llegará cerrar Word, tendrá que reiniciar el sistema y recordar que el trabajo hecho hasta ese punto, se presentará nuevamente como si no estuviera hecho, pues fue interrumpido.

Imprimir uno a uno

Se genera el documento, con los datos individuales insertados, y se imprime uno a uno. Antes de continuar con el siguiente documento, se espera a que toque el mensaje ¿continúa?

Imprime continuos

Genera cada documento y lo envía a impresión, sin interrupción, hasta terminar con todos los documentos programados. Cuando el número de documentos es grande, puede exceder la capacidad de la computadora, por que el programa los genera a velocidad mayor de lo que la computadora puede imprimirlos y por tanto debe guardarlos en la memoria temporal, que puede ser excedida. En este caso, autorice la ejecución de 15 o 20 en cada corrida.

Se iniciará la generación de los documentos en Word, usando el archivo de Word que tiene registrado en la Actividad de esa acción, insertando los datos de cada deudor.


II.1.4.2 - Formatos preimpresos

Coloque los formatos en la impresora y, si es la primera vez que va a usar este formato, verifique con una sola impresión que todo funciona correctamente. Puede elegir entre:

Imprimir uno a uno: se imprime el formato y antes de continuar, espera que toque [Continua].

Imprime todos: imprime en forma continua todo los trabajos autorizados.


II.1.4.3 – Email (Correo Electrónico)

El sistema controla directamente el programa de correo habitual de su computadora, usualmente Outlook, por lo que no debe interferirse; esto significa que no debe tenerlo abierto cuando use esta función, ni cerrarlo mientras este ejecutando esta función.

Para enviar el primer correo electrónico, se carga a la memoria de la PC el programa de correo, lo que tarda algunos segundos. Para cada correo electrónico autorizado, se insertan los datos individuales en cada correo y se envía.

Consulte el manual del programa de correo para configurar la forma de envío, que puede ser inmediata si está conectado a Internet, o bien simplemente genera los correos y los deposita en la bandeja de salida hasta que se le ordene enviarlos.


II.1.4.4 – Fax

Genera un documento en Word para enviarlo por Fax, y se maneja como lo indica el inciso anterior para Documentos. El sistema controla directamente el programa Word, por lo que no debe interferirse; esto significa que no debe tener abierto Word cuando use esta función, ni cerrarlo mientras este ejecutando esta función.

Cuando se genere la página en Word, que puede modificar antes de enviar, al imprimir elija la impresora de Fax.


II.1.4.5 –Telefonema

Cuando el responsable de esta actividad pide la ejecución de los telefonemas, se presenta una ventana con los datos del deudor y sus teléfonos.

Al realizar el telefonema, puede hacer lo siguiente:

Llamadas anteriores: Presenta la relación de las llamadas anteriores a ese deudor, para revisar el historial y saber como debe proceder ahora.

Quien: Le presenta la pantalla con la información del deudor, a quien está llamando.

Anotar: Presenta la información de la acción, que le indica lo que debe hacer, y sirve para registrar los avances del caso, si los hubo. Si se cumplió el objetivo, el estado de la acción se pasa de ‘Planeada’ a ‘Realizada’

Cancela: El telefonema no pudo realizarse.

Termina: El telefonema se realizó y se anotaron los avances, si los hubo. Para llevar un registro de los telefonemas, sean o no exitosos, se pide anotar el resultado de la llamada: No contesto, esta de viaje, le dejé recado, etc.


II.1.4.6 - Visitas

Para las visitas, se genera una orden de Visitas que es un documento de Word, con los datos del deudor: nombre, dirección, teléfonos, etc. El formato usando puede modificarlo para adecuarlo a sus necesidades, y está en el archivo Visita.doc que puede encontrar en el mismo subdirectorio en que está instalado el programa.

Para cada visita se insertan en este documento los datos individuales del deudor, para ser impresos en Word.

El sistema controla directamente el programa Word, por lo que no debe interferirse; esto significa que no debe tener abierto Word cuando use esta función, ni cerrarlo mientras este ejecutando esta función.


II.2 – PROGRAMA ACTIVIDADES

Para calendarizar las acciones planeadas el programa las genera en forma automática, programándolas según la fecha inicial del Procedimiento asignado, a la que suma los días posteriores que marca la actividad. Pero no todos los planes se cumplen, y resulta necesario reprogramar las acciones, modificando su fecha, estado o responsable.


II.2.1 – Reprograma

Para revisar y reprogramar las acciones planeadas que no se realizaron. Se pide una fecha de comparación, para presentarle a modificación solo las acciones planeadas antes de esta fecha.

Podrá hacer la reprogramación, considerando los avances reportados en el campo: Notas, modificando la fecha planeada, cambiando su estado a Cancelada o Realizad, asignando otro Responsable


II.2.2 – Calendario

Sirve para revisar el calendario de actividades para cada Responsable, e imprimirlo. Inicialmente se definen las fechas inicial y final del período deseado. Se presentan las acciones planeadas en ese período, y podrá seleccionarlas por Responsable, para imprimir el Calendario de cada uno.


II.3 – P A G O S Y CARGOS

Para registrar y modificar los pagos recibidos, por su Agencia o por su Cliente, de cada deudor, obtener la información que requiere para planear futuras acciones y supervisar el estado general de la cobranza, dispone de las siguientes funciones.


II.3.1 – Registra

Al recibir un pago, o confirmar que el deudor depositó un pago al cliente, se debe registrar. Con ello tienen los datos en su sistema para obtener los estados de cuenta, hace el seguimiento de las comisiones correspondientes y otros efectos. Se recomienda restringir el acceso.

Para ellos, se presenta un Panel con campos para los Datos, como se describe a detalle en {III.12} Escriba los Datos y pase de un campo a otro con las teclas [TAB] para avanzar [Shift] [TAB] o para retroceder, o bien tocando con el ratón el campo deseado.

El color de fondo le indica el estado de cada Campo: campos aún no modificados son amarillos, los campos modificados son azules, el campo vigente es blanco y los no modificables, tienen color salmón. Si se detecta algún problema, el color del campo será rojo, indicando que tendrá que corregir su contenido antes de terminar.

Las teclas inferiores le permiten:

[Termina] | Habiendo revisado que los datos anotados son correctos, se registran los datos y regresa al Menú
[Cancela] | Sin registrar los datos escritos se regresa al Menú
[Otra] | Registra los datos escritos y repite la captura


II.3.2 – Modifica

En algunos casos deberá modificar los pagos anteriormente registrados, pero como esto es una información crítica, se le recomienda restringir el acceso.

Se presenta un panel con los datos de cada Pago, en su esquina inferior derecha tiene un [Navegador], que le permite mover el Pago visible e indica la secuencia del que es presentado y total de los existentes. En sus extremos tiene puntas que al ser tocadas con ratón permite avanzar ó retroceder, de uno en uno ó hasta el límite. Ver {III.13}.

Los datos: Recibió y Deudor no pueden escribirse, pues tienen que ser alguno de los Responsables y Deudores registrados en el sistema; para modificarlos se requiere un doble toque, y se presentará una lista para que elija al que corresponda.

Con las teclas inferiores puede:

[Elimina] | Para eliminar este registro, se presentará una confirmación
[Termina] | Habiendo revisado que los datos anotados son correctos, se registran los datos y regresa al Menú
[Cancela] | Sin registrar los datos escritos se regresa al Menú


II.3.3 – Revisión

Para revisar en una forma ágil los pagos realizados por deudores, se presentan 3 listas relacionadas entre sí: para clientes, deudores y pagos. Tocándolas en este orden permite revisar los deudores de cada cliente y los pagos de cada deudor, así como los datos completos de ese pago o deudor en la ventana de texto inferior.

Además de la revisión, puede también agregar nuevos clientes, deudores y pagos, modificar los existentes y eliminarlos; para ello señale la lista deseada, usando toque derecho (señala un elemento de la Lista con el cursor y oprime el botón derecho del ratón). Elige entre las opciones, según la Lista que toque:

[Modifica] un cliente, deudor o Pago. También puede eliminarlo

[Tabla] presenta una tabla de clientes, deudores o pagos, con datos completos y las posibilidades de imprimir un reporte, escoger u ordenar

[Busca] al cliente o deudor, usando algunas letras de su nombre; o Pagos dentro de un rango de cantidades.

Para finalizar, toque le tecla [Termina]


II.3.4 – Consulta

La información de Pagos puede consultarla e imprimirla, organizando los pagos por deudor o fecha de registro, y también según la persona o Cliente que los recibió. Si le interesa la información organizada por otro concepto, puede usar la consulta general para escoger aquellos pagos de su interés.

Inicialmente se pide que ingrese un periodo de fechas, para presentar en la tabla solo aquellas cuyo inicio es posterior o cuyo termino es anterior al periodo definido.

La información se presenta en forma Tabular, con una fila para cada Pago, con sus datos en columnas cuyos títulos definen el significado. Puede señalar una fila, tocándola con ratón; moverla con las teclas de [flecha arriba-abajo], [AvPag] y [RePag].

Si las filas exceden la ventana, aparece una banda horizontal con cursor que permite mover las filas, tocando la banda o arrastrando el cursor. Si las columnas exceden la ventana, aparece una banda vertical con cursor que permite mover las filas, tocando la banda o arrastrando el cursor.

Las teclas inferiores sirven para disponer de las siguientes opciones:

[Selecciona] | Le permite escoger aquellos registros que cumplan ciertas condiciones. {III.131}
[Ordena] | Para que pueda dar la secuencia deseada a los Registros {III.132}
[Imprime] | Imprime o exporta los datos de la Tabla, sean visibles ó no
[Termina] | Termina la revisión de datos y regresa al Menú


II.3.4.1 - Consulta General

Información de todos los Pagos, para imprimir, escoger y ordenar. Puede obtener con ella información específica: por ejemplo, que pagos hizo un deudor específico en un período de fechas, que pagos fueron recibidos por alguno de los responsables en el 5 de noviembre, etc.


II.3.4.2 – Recibió

Se pregunta la fecha máxima y mínima que debe considerarse para que después se presente la información solicitada en forma de una lista tabular {lista tabular}.

Esta consulta permite conocer el detalle que de los pagos recibidos por personal de la agencia, que esté registrado como responsable en este sistema, o directamente por el cliente, lo que puede ser muy útil para aclarar confusiones.


II.3.4.3 - Deudor

Los Pagos de cada Deudor, ordenados por fecha, se pueden consultar o imprimir en esta función. Ello sirve para conocer su puntualidad en el cumplimiento de la deuda, resolver dudas del estado de cuenta, y otros efectos.

Primero se elige al Deudor de una lista, esto se consigue con doble toque sobre el nombre del Deudor y posteriormente aparecerá la información en una lista tabular {lista tabular}.


II.3.4.4 - Fecha

A continuación se presentan todos los Pagos, ordenados por fecha, dentro del período considerado en un formato tabular.


II.3.5 – Estadística Pagos

Las funciones anteriores presentan el detalle de los pagos, y las que a continuación se describe obtienen los totales {III.41} de los Pagos, que son una forma rápida de supervisar el proceso de cobranza. Esto se hace especificando un periodo de fechas, se pide que ingrese la fecha mínima y máxima.

En estos cuadros de resumen, para mover las Filas use [Flecha Arriba-Abajo] ó toque con el ratón la banda del extremo derecho. Las bandas horizontal y vertical de la Tabla permiten mover la zona visible, tocándola con ratón. Si todo es visible, se omite la banda. Ver {III.21}.

Con las teclas inferiores, tiene:

[Imprime] | Imprimir o exportar la Tabla, incluso las filas y columnas no visibles en la pantalla
[Gráfica] | Presenta en la pantalla la Gráfica correspondiente a la Tabla Estadística
[Termina] | Regresar al Menú

Si usa [Gráfica], produce una Gráfica Estadística con los Datos de la Tabla. La Gráfica se presenta a color en la pantalla y puede elegir entre las opciones:

[Estilo] | La Gráfica se presenta en ocho estilos diferentes, 4 de dos dimensiones y 4 de tres dimensiones, que puede elegir en una Lista de Estilos
[Impresión] | Si es impresora de color, se reproduce la Gráfica a colores; pero si no, cada color se convertirá en un tono de gris, para poder ser impresa en blanco y negro
[Título] | Puede modificar el título de la Gráfica, que originalmente es el mismo del Resumen Estadístico, para explicar con precisión su significado


II.3.5.1 – Recibió

Reporta la suma de Pagos, por Receptor, en el período considerado.


II.3.5.2 - Deudor

Reporta la suma de Pagos, de cada Deudor, en el período considerado.


II.3.5.3 - Fecha

Reporta la suma de Pagos, en un período de fechas considerado.


II.3.5.4 – Clientes

Presenta en pantalla y para impresión un Reporte de Pagos para Clientes, que especifica las acciones de cobranza y los pagos logrados del Deudor.


II.3.6 - Estadística Cargos

Los resúmenes estadísticos le permiten revisar la forma en que se han manejado los cargos, desde diversos puntos de vista


II.3.6.1 – Deudor

Presenta la estadística de cargos a cada deudor, clasificada por su tipo


II.3.6.2 – Clientes

Presenta la estadística de cargos relativos a cada cliente, clasificada por su tipo, en el período que defina.


II.3.7 – Reportes Pagos

Estos reportes sirven para revisar los pagos para cada cliente, en forma estadística, en el período de fechas que defina.


II.3.8 – Estado de Cuenta

Para obtener los pagos y cargos de cada deudor, y sus totales. Inicialmente elige al deudor, y se presentan sus pagos y cargos, que puede imprimir y exportar a una hoja de calcula, como Excel, para hacer los cálculos que requiera: intereses, comisiones, etc.


II.3.9 – Saldos

Para facilitar el reporte de pagos y cargos a deudores que piden sus clientes, se obtienen los totales de pagos y cargos de cada deudor, que puede imprimir.


II.4 – D E U D O R E S

Para manejar la información sobre Deudores, se dispone de funciones para su captura, modificación, consulta y cálculo de su estado de cuenta, que se explicará continuación.


II.4.1 – Captura

Para registrar los Datos del Deudor se presenta un Panel con campos para capturar los Datos {III.12} Escriba los Datos y pase de un campo a otro con las teclas [TAB] para avanzar y [Shift] [TAB] para retroceder, o bien tocando con el ratón el campo deseado.

El dato Cliente no debe escribirse, porque sería fácil equivocarse si no se recuerda con precisión el nombre completo usado para registrarlo, y un error tendría consecuencias en las estadísticas y consultas; por ello se utiliza un dato de tipo apuntador, que al intentar escribir presenta una lista de los registrados, para que elija al que corresponde.

Los datos clase y situación, puede usarlos para clasificar a los deudores como acostumbra. Para modificar los clasificadores usados por defecto, vea el inciso {II.7.3} Los clasificadores se usan para evitar errores de teclado, pues son datos que no pueden escribirse y sólo permiten elegir una de las opciones presentadas en la lista {III.5}

Las teclas inferiores le ofrecen las siguientes opciones:

[Termina] | Habiendo revisado que los datos anotados son correctos, se registran los datos y regresa al Menú
[Cancela] | Sin registrar los datos escritos se regresa al Menú
[Otra] | Registra los datos escritos y repite la captura


II.4.2 – Modifica

Para modificar o eliminar los registros de los Deudores, se recomienda restringir el acceso, ya que se trata información importante.

Para Modificar ó Eliminar un Deudor, se presenta un panel con los datos, que en su esquina inferior derecha tiene un [Navegador], que le permite mover el Deudor visible e indica la secuencia del que es presentado y total de los existentes. En sus extremos tiene puntas que al ser tocadas con ratón permite avanzar ó retroceder, de uno en uno ó hasta el límite. Ver {III.13}

Con las teclas inferiores, puede:

[Elimina] | Si quiere eliminar este Registro,
[Cancela] | Sin registrar los datos escritos se regresa al Menú
[Termina] | Habiendo revisado que los datos anotados son correctos, se registran los datos y regresa al Menú
[Selecciona] | Le permite escoger aquellos registros que cumplan ciertas condiciones. {III.131}


II.4.3 – Consulta

Frecuentemente requerirá consultar la información sobre Deudores, verse en diversas formas de presentar la información: general, organizada por cliente, por la situación o clase del deudor, así como listados por el número de expediente.

La información se presenta en forma Tabular, con una fila para cada Deudor, con sus datos en columnas cuyos títulos definen el significado. Puede señalar una fila, tocándola con ratón; moverla con las teclas de [flecha arriba-abajo], [AvPag] y [RePag]

Si las filas exceden la ventana, aparece una banda horizontal con cursor que permite mover las filas, tocando la banda o arrastrando el cursor. Si las columnas exceden la ventana, aparece una banda vertical con cursor que permite mover las filas, tocando la banda o arrastrando el cursor.

Las teclas inferiores sirven para disponer de las siguientes opciones:

[Selecciona] | Le permite escoger aquellos registros que cumplan ciertas condiciones. {III.131}
[Ordena] | Para que pueda dar la secuencia deseada a los Registros {III.132}
[Imprime] | Imprime o exporta los datos presentados, incluyendo todos las filas de la Tabla, sean visibles ó no
[Termina] | Termina la revisión de datos y regresa al Menú


II.4.3.1 - Consulta General

Esta consulta presenta a todos los deudores, con facilidades para escoger aquellos que interesan, ordenarlos e imprimir el formato tabular. Cuando desea información que no le brinda el las consultas posteriores, puede usar esta consulta general para obtener, usando la selección y ordenación, la información que necesite.


II.4.3.2 – Cliente

En esta ventana presenta una lista de los deudores, ordenados por el cliente que encargó el proceso de cobranza, y es de utilidad cuando desea una lista impresa con esta organización.

Inicialmente se le pide que seleccione un cliente de la lista presentada, haciendo doble toque sobre su nombre para que posteriormente se presente la información solicitada en una lista tabular, {lista tabular}.


II.4.3.3 – Situación

Aquí se presenta una lista de deudores, organizada según la situación de cada deudor. La situación es un clasificador que usted utiliza para calificar las posibilidades de cobranza, y por tanto esta lista ayuda a evaluar el panorama de estas posibilidades, esto se consigue haciendo doble toque sobre las opciones que presenta la ventana: Regular, Vencido, Baja o Incluir Todas.

Una vez seleccionada la situación aparece una ventana con la información tabular {lista tabular}.


II.4.3.4 – Clase

La clase del deudor, es un dato que le ayuda clasificar el proceso de cobranza que aplica en cada Deudor, Administrativo, etc. Al organizar la lista de deudores por Clase, puede prever las cargas de trabajo en estos diferentes procesos.

Se pide que seleccione la Clase de Deudor: Administrativa, Pre-Juridica, Jurídica o Incluir Todos, esto se hace con doble toque para que aparezca la información seleccionada en una lista tabular {lista tabular}.


II.4.4 – Procedimiento

Las fases de la cobranza pueden ser múltiples, pues según los resultados de una fase, se puede necesitar otra: por ejemplo, a un deudor que no atiende los requerimientos de pago, se tiene que pasar a la fase jurídica. Esto significa que se agregan nuevas acciones, correspondientes al procedimiento jurídico.

Para ello, se elige al deudor

Y luego se elige el nuevo procedimiento que se le asigna.

Ahora se pasa a generar las nuevas acciones correspondientes al nuevo Procedimiento, para lo que se pide la fecha inicial de estas acciones.

Se agregan las nuevas acciones al deudor, a partir de la fecha inicial.

Si el deudor tenía acciones anteriores pendientes, estas seguirán apareciendo cuando se organice el trabajo; por lo que es recomendable revisar y modificarlas para cerrar el ciclo anterior, reprogramando, suspendiendo o eliminando las acciones no realizadas, según corresponda. Esto puede hacerlo con la función del siguiente inciso.


II.4.5 – Acciones

Para facilitar el trabajo de seguimiento de las acciones a un deudor específico, aquí selecciona un deudor, para ver y modificar las acciones de este.

Primero elige si desea manejar todas o solo las planeadas, realizadas o suspendidas; las que haya elegido se presentan en un panel que permite modificar sus datos ó eliminarlas. Puede moverse entre las acciones usando el navegador, abajo a la derecha.


II.5 – C O M I S I O N E S

Los Pagos de los Clientes, por gestiones de cobranza, que llamamos comisiones, se deben registrar, en algunos casos modificar, frecuentemente consultar para mantener al día los ingresos de la agencia y aclarar dudas diversas, y finalmente obtener los totales, que por diversos conceptos, se ha obtenido por comisiones.


II.5.1 - Registra

Como el registro de comisiones representa un ingreso, sobre el que hay que mantener un control estricto, se recomienda restringir el acceso con una contraseña.

Se presenta un panel para registrar el cliente y el deudor, el monto de la comisión, su fecha y concepto. Nótese que los datos del cliente y deudor tienen no tienen que escribirse, sino seleccionar entre los clientes y deudores registrados en el programa.

Presenta un Panel con campos para capturar los Datos, como se describe a detalle en {III.12} Escriba los Datos y pase de un campo a otro con las teclas [TAB] para avanzar y [Shift] [TAB] para retroceder, o bien tocando con el ratón el campo deseado.


II.5.2 - Modifica

Para modificar o eliminar los ingresos por comisión, se recomienda restringir el acceso con una contraseña, ya que se trata de información crítica. Quien la tenga podrá acceder a la ventana que permite Modificar los ingresos por Comisión ó Eliminarlos.

Para revisar las Comisiones, se presenta un panel con los datos de cada una, que en su esquina inferior derecha tiene un [Navegador], que le permite moverse entre ellas e indica la secuencia del que es presentado y total de los existentes (1 de 4). En sus extremos tiene puntas que al ser tocadas con ratón permite avanzar ó retroceder, de uno en uno ó hasta el límite. Ver {III.13}.

[Elimina] | Para eliminar este registro, confirmando se borra
[Termina] | Habiendo revisado que los datos anotados son correctos, se registran los datos y regresa al Menú
[Cancela] | Sin registrar los datos escritos se regresa al Menú

Nótese que los datos del cliente y deudor no se escriben sino que con un doble toque sobre el dato presentará una tabla en donde podrá elegir al cliente o deudor correspondiente.

El concepto, tampoco se escribe por ser un clasificador que sólo admite indicar una de las opciones presentadas; para modificar el concepto habrá un doble toque sobre el clasificador para que se abra la ventana de acciones, o también puede hacerlo navegando hasta que ese campo con la tecla [TAB].

Si lo elimina aparecerá un mensaje para confirmar que será borrado de los registros.


II.5.3 – Consultas

La información sobre Comisiones se presenta en forma Tabular, con una fila para cada Acción con sus datos en columnas cuyos títulos definen el significado. Puede señalar una fila, tocándola con ratón; moverla con las teclas de [flecha arriba-abajo], [AvPag] y [RePag].


II.5.3.1 – Cliente

Para conocer el detalle de las comisiones que ha pagado cada uno de los clientes, se presenta una ventana tabular que ofrece esta información. Se pide una fecha inicial para considerar las actividades realizadas desde esa fecha inicial hasta el momento.


II.5.3.2 – Deudor

También puede ser necesario consultar las comisiones recibidas, pero organizadas por deudores en vez de clientes, ya que esto permite verificar si está en completamente pagadas, o conocer su historial.


II.5.3.3 – Fechas

Inicialmente se pide que ingrese un periodo de fechas, para presentar en la tabla solo aquellas cuyo inicio es posterior o cuyo termino es anterior al periodo definido. Se pregunta la fecha máxima y mínima que debe considerarse.

Para el control de ingresos que es muy conveniente tener a mano la información detallada de los ingresos recibidos por comisiones, ya que permite conciliar las cuentas de ingresos.


II.5.4 – Estadísticas

Las estadísticas le brindan una visión sintética del manejo de las comisiones, presentándole un cuadro estadístico, cuyas las teclas inferiores, tiene la opción de:

[Imprime] | Imprimir o exportar la Tabla, incluso las filas y columnas no visibles en la pantalla
[Gráfica] | Presenta la Gráfica correspondiente a la Tabla Estadística
[Termina] | Regresar al Menú

La Gráfica se presenta a color en la pantalla y puede elegir entre las opciones:

[Estilo] | La Gráfica se presenta en ocho estilos diferentes, 4 de dos dimensiones y 4 de tres dimensiones, que puede elegir en una Lista de Estilos
[Impresión] | Si es impresora de color, se reproduce la Gráfica a colores; pero si no, cada color se convertirá en un tono de gris, para poder ser impresa en blanco y negro
[Título] | Puede modificar el título de la Gráfica, que originalmente es el mismo del Resumen Estadístico, para explicar con precisión su significado


II.5.4.1 – Cliente

Presenta el Total de Comisiones que ha pagado cada Cliente. Se pide una fecha inicial para calcular los totales cobrados desde esa fecha inicial hasta el momento, se disponen de varios cuadros de totales {III.41}.


II.5.4.2 – Deudor

Presenta el total de comisiones que se ha cobrado por el proceso de cobranza de cada Deudor. Se pide una fecha inicial para calcularlas desde esa fecha inicial hasta el momento.


II.5.4.3 - Fecha

Se pide una fecha, a partir de la cual se contabilizan todas las comisiones pagadas por los clientes, organizadas por mes. Este cuadro le permite revisar la evolución de los ingresos de la agencia de cobranza.


II.6 – GASTOS

Los gastos de operación se manejan en las siguientes funciones, y cada gasto puede relacionarse con un responsable, que es quien hace el gasto, y con un deudor, si el gasto fue originado por él y debe cargarse a su cuenta.


II.6.1 – Captura

Los gastos se registran en un panel, clasificando su tipo (Los tipos puede adecuarlos a su necesidad {II.7.3}) y asignarlas a un Responsable y a un Deudor, si es el caso.


II.6.2 – Modifica

Los gastos antes registrados pueden modificarse o eliminarse.


II.6.3 – Consultas

Para revisar los gastos, cuenta con las siguientes funciones.


II.6.3.1 – Consulta Gral

Presenta todos los gastos, y puede elegir los de su interés, ordenarlos e imprimirlos.


II.6.3.2 – Deudor

Para revisar los gastos relacionados a un deudor específico, se elige al deudor, y si se tienen gastos registrados a él, se presentan.


II.6.3.3 – Responsable

Para conocer los gastos de cada colaborador, en un período definido de fechas, se elige al Responsable para presentar los gastos asignados a él, en formato tabular.


II.6.3.4 – Fechas

Se reportan en forma detallada los gastos registrados en un período, para que pueda imprimir un reporte, ordenando y seleccionado los gastos conforme su necesidad.


II.6.4 – Estadísticas

Para controlar los gastos, los reportes estadísticos le dan información resumida por deudor, responsable y fecha, clasificándolos por su tipo.


II.6.4.1 – Deudor

Total de gastos originados por cada deudor.


II.6.4.2 – Responsable

Cuanto y en que gasta cada colaborador.


II.6.4.3 – Fecha

¿Cuánto y en que está gastando? Total mensual de gastos, clasificados por tipo, en un período de fechas que define.


II.7– UTILERIAS

Contiene diversas funciones que le permiten mantener el Sistema y adaptarlo a propósitos específicos, Se recomienda restringir el acceso.


II.7.1 – Respaldo BD

En el uso cotidiano, al escribir y modificar Datos, la Base de Datos los agrega sin eliminar los anteriores, por lo que crece su tamaño. Por tanto, es conveniente compactar la Base de Datos cada mes, lo que crea una versión nueva conteniendo solo los datos válidos, evitando así que llegue a ser demasiado voluminosa y, por tanto, su velocidad de acceso sea mas lenta; así como facilitar el respaldo de la misma. La versión antigua queda grabada con el mismo nombre pero extensión BAK.

La información registrada en el Sistema se almacena en la Base de Datos, que debe ser respaldada periódicamente. Es recomendable copiarla al menos una vez a la semana en otro Disco, o al menos en otro subdirectorio del mismo disco duro; esta precaución puede evitar graves problemas si su computadora sufre algún percance mayor, que destruye las información almacenada en disco duro.


II.7.2 - Repara BD

La información que éste y cualquier programa de computadora, almacena en su disco duro, puede deteriorarse cuando hay una falla en la energía eléctrica; por ello es recomendable el uso de una Fuente ininterrumpible para alimentar su Computadora, pues son frecuentes las ocasiones en que baja el voltaje de la línea más allá de lo permitido por las especificaciones de su computadora, aun por algunos décimos de segundo, y si coincide en el momento que se estaba escribiendo un dato en el disco duro, habrá un error en sus Datos.

El síntoma de estos errores se obtiene cuando intenta leer los datos afectados y se tiene un mensaje de Error que indica la imposibilidad de leer o escribir en la Base de Datos.

Cuando esto acontece, si el daño es menor la propia base de Datos tiene mecanismos para repararse, que se manejan en esta función. La máquina de Base de Datos Jet 3.5 de Microsoft, intenta rehacer la continuidad de la información; y por medio de mensajes en la pantalla le informa los resultados.

Si aún reparándola no pueden leerse los datos, tendrá que usar el respaldo explicado en {II.71} para lo cual conviene copiar la base de Datos dañada a otro subdirectorio y renombrar el respaldo, que tiene el mismo nombre pero con extensión BAK.

La información capturada después del respaldo tendrá que actualizarla manualmente.


II.7.3 – Clasificadores

En la captura y modificación de datos se utilizan en ocasiones una lista de posibles respuestas, para seleccionar entre ellas, en vez de campos para escribirlas. Así se asegura la uniformidad de estos datos, lo que es importante cuando se emplean para clasificar una información, y algún error de ortografía podría causar error. Es particularmente importante en los clasificadores utilizados para las estadísticas.

Se presenta a selección los distintos Clasificadores que usa el Sistema, que elige señalando su fila y eligiendo con la tecla [Intro], para que se presenten las opciones del Clasificador elegido en una Tabla, en donde puede modificar, agregar o eliminar. Para cancelar, use tecla ESC Ver {III.22}.

El Sistema contiene los clasificadores normales, pero usted puede eliminarlos si representan conceptos no usados en su Partido, modificarlos y agregar nuevos clasificadores, que le permita ajustar el sistema a sus necesidades, pero antes convendría que revisara las funciones del Sistema que los utilizan, ya que algunas de ellas podrían ser incompatibles con los cambios


II.7.4 – Acceso

Con la finalidad de proteger los datos de su Empresa, que se capturan y manejan en este Programa, puede restringir el acceso a las funciones que contienen información reservada, que sólo podrán ejecutarse por el personal autorizado por medio de Contraseñas de acceso. Una Contraseña está compuesta de letras ó números, (15 caracteres máximo) que identifica a cada usuario del sistema

Al iniciar el programa, se pide al usuario identificarse con su contraseña, y se comprueba que esté registrado como usuario del sistema; sino, se impide la ejecución del sistema. Al escribirla no se muestran en pantalla los caracteres, sino solo asteriscos, con la intención que terceras personas no puedan verla en la pantalla.

Cuando el usuario accesa a un menú, se comprueba si está autorizado para ejecutarla. Al instalar el sistema, ninguna función tiene restricción de acceso, para que pueda decidir cuales son críticas para su caso y defina como diseña la restricción.

Para diseñar las restricciones de acceso, se procede así:

1 – Planear las restricciones del menú de funciones

Usando el menú Utilería – Acceso – Funciones – Modifica, presenta en tabla las funciones del sistema, con el nombre, descripción del menú y dos datos: Nivel y Grupo, que definen la restricción de acceso.

· Si el menú tiene Nivel vacío y Grupo vacío, todos pueden acceder a esa función (Así están inicialmente todos los menús, hasta que Ud. lo restrinja escribiendo un Nivel o Grupo)

· Si en el menú escribe un Nivel: 1, 2, 3,.. sólo podrán accesarlo los usuarios cuyo nivel sea igual o mayor. Si el nivel del usuario es menor, se negará el acceso.

· Si en el menú escribe un Grupo: A, B, C,….. sólo podrán accesarlo los usuarios con el mismo Grupo ó sin Grupo, si su nivel lo permite; si tiene un Grupo diferente, no podrá accesarlo, aunque su Nivel sea mayor.

2 – Imprima esta tabla, que le ayudará a planear las restricciones. No escriba restricciones en esta etapa, pues luego no podrá acceder el programa, ya que aún no autoriza usuarios. Identifique que menús desea restringir; y agrúpelos en niveles sucesivos: 1, 2, 3, …

Ahora revise que nivel dará a los usuarios para que puedan ejecutar las funciones que necesitan. Si con ello está satisfecho, no necesitará usar los Grupos.

Pero si requiere que algunas funciones estén restringidas para usuarios con nivel suficiente, puede asignar un Grupo: A, B, C, …. a las funciones, y asigne el mismo Grupo a los usuarios que solo podrán acceder a esas funciones, pero no las demás funciones; y deje vacío el Grupo de los usuarios que deberán acceder a todas la funciones, si su nivel lo permite.

3 – Autoriza a los usuarios

Usando el menú Utilería – Acceso – Usuario – Crea, presenta un panel donde registra a los usuarios. A cada usuario le asigna una clave ó contraseña y un Nivel, y puede asignarle un Grupo. A partir de éste momento, el sistema requerirá una contraseña válida para ejecutar el programa, por lo que es importante:

· Registrar un Administrador del Sistema, con Nivel máximo y sin Grupo, para que siempre pueda ejecutar todas las funciones.

· Asignar a todos los menús de: Utilería – Acceso – Usuario y Utilería – Acceso – Funciones, un nivel máximo y sin Grupo, para que solo el Administrador pueda modificar las restricciones y usuarios

· Distribuir las contraseñas a los usuarios, recomendándoles discreción y no escribirla donde otros puedan verla.

· Tener impresa la lista de usuarios, usando el menú Utilería – Acceso – Usuario – Consulta.

4 – Define las restricciones de los menús

Vuelva a usar el menú Utilería – Acceso – Funciones – Modifica, para escribir el Nivel y, si es el caso, Grupo que ha planeado para cada menú. A partir de éste momento, se restringen las funciones

Si posteriormente desea modificar los usuario, use el menú Utilería – Acceso – Usuario– Modifica; y para modificar el acceso a menús, el menú Utilería – Acceso – Funciones – Modifica. El manejo de estas Tablas puede verlo en {III.22}, que describe como modificar, eliminar y agregar registros.

Puede obtener un reporte impreso de Usuarios y Menús, usando: Utilería – Acceso – Funciones – Consulta y Utilería – Acceso – Usuarios - Consulta


II.7.5 – Licencia

Para realizar los pagos por el Sistema, se necesita enviar la información que esta función presenta: Clave de la computadora que tiene instalado el sistema – que es imprescindible - los datos del comprador, métodos alternativos de pago y teléfonos ó correo electrónico para comunicarse para solicitar asesoría.

Esta información se presenta en el Block de Notas, para facilitar su envío por Fax, Correo electrónico ó Teléfono, ya que puede leerla, copiarla y pegarla ó imprimirla; puede también grabarla en un disco si usa otro nombre o un subdirectorio diferente al que contiene el original, y mantener este formato sin cambios.

Es importante que llene sus datos, pues con ellos le enviamos, a cambio del pago, la Clave de Licencia que autoriza la ejecución del Sistema.


II.7.6 – Registra

Al recibir los datos de la Licencia, descritos en inciso anterior, y su pago, le enviaremos la Clave de Licencia que autoriza la operación del Sistema. Esta Clave se escribe en el campo blanco, terminando con [Intro]

Si la Clave es correcta, el Sistema podrá operar; en caso contrario se avisa el tipo de error detectado en la Clave de Licencia, que puede ser:

· Esta mal escrita la Clave. Revísela con cuidado para verificar que es idéntica (incluso minúsculas y mayúsculas)

· El reloj de la computadora tiene una fecha errónea, por lo que no puede interpretarse la Clave

· La clave escrita pertenece a otra computadora. El mismo Sistema tiene Claves diferentes para cada computadora en que se instala.

En caso de duda, comuníquese con nosotros por teléfono o correo; el archivo Registro.txt contiene estos datos.


II.8 – IMPLANTACIÓN

Antes de usar el Sistema, es necesario registrar información básica que es usada en las demás funciones: Clientes, Responsables. Y configurar la forma de operación deseada, pues cada empresa opera en forma diferente y debe adaptarse la funcionalidad del sistema a sus necesidades.


II.8.1– Clientes

Los clientes, quienes encargan la cobranza de sus deudores, requieren ser registrados, modificados y consultados. Sus datos son usados en diversas partes del programa.


II.8.1.1 - Captura

Para capturar los datos de los clientes se presenta un panel que permite escribir su nombre o razón social, la oficina a la que se reporta la cobranza y nombre de la persona que es el contacto.

En el campo notas podrán escribirse las observaciones específicas para ese cliente: como desea ser informado sobre la cobranza a sus deudores, particularidades del trato con él. Las teclas inferiores sirven para:

[Termina] | Habiendo revisado que los datos anotados son correctos, se registran los datos y regresa al Menú
[Cancela] | Sin registrar los datos escritos se regresa al Menú
[Otra] | Registra los datos escritos y repite la captura


II.8.1.2 – Modifica

En algún momento tendrá que modificarse alguna información o eliminación de los clientes.

Las teclas inferiores son para:

[Elimina] | Si acepta la eliminación, procede a borrar este Registro
[Termina] | Habiendo revisado que los datos anotados son correctos, se registran los datos y regresa al Menú
[Cancela] | Sin registrar los datos escritos se regresa al Menú


II.8.1.3 – Consulta

Se presenta una tabla para consulta en pantalla de los Clientes.

Las teclas inferiores sirven para disponer de las siguientes opciones:

[Selecciona] | Le permite escoger aquellos registros que cumplan ciertas condiciones. {III.131}
[Ordena] | Para que pueda dar la secuencia deseada a los Registros {III.132}
[Imprime] | Imprime o exporta los datos de la Tabla, sean visibles ó no
[Termina] | Termina la revisión de datos y regresa al Menú


II.8.2 – Procedimientos

Para generar en forma automática a cada nuevo deudor las actividades que corresponden a su caso, se agrupan los conjuntos de actividades habituales en Procedimientos, que se manejan en estas funciones que capturan, modifican y reportan sus datos.


II.8.3 – Responsables

Los datos de quienes realizan los trabajos, se capturan, modifican y reportan en estas funciones.


II.8.4 – Actividades

Las actividades habituales que se realizan, agrupadas en procedimientos, se registran, modifican y consultan en estas funciones. Al registrar cada nuevo deudor, le asigna un Procedimiento, y se generan automáticamente acciones para cada Actividad asociada a ese Procedimiento, con el mismo nombre y planeadas con fecha calculada sumando a la Fecha inicial los días posteriores al inicio que registra en el dato: Dias_Post de la actividad.

El dato Tipo, es importante porque permite automatizar trabajos predefinidos.

Si usa algunas de estas clasificaciones, debe registrar el dato: Archivo, como lo indica el Diseño de Documentos {II.8.5}

· Documento: Imprime un formato de Word

· Formato: Imprime los datos sobre un formato preimpreso

· Fax: Genera un documento en Word, para envío por Fax

· EMail: Envía un correo electrónico

· Telefonema: Para que un operador realice telefonemas

· Visita: Imprime una orden de visita

Si no son trabajos predefinidos, puede usar los clasificadores: Oficina y Otros


II.8.4.1 – Captura

Al capturar los datos de la actividad, use Tipo para definir el tipo de trabajo, Procedimiento para asignar la actividad a un procedimiento (al intentar escribir, se presentan los Procedimientos registrados, para que elija uno), similarmente, Responsable presenta los responsables registrados para elegir al encargado de realizar la actividad.


II.8.4.2 – Modifica

Puede modificar los datos de la actividad. En especial, si es una Actividad que usa un Tipo que genera documentos, EMail, etc. al cambiar el diseño se debe actualizar el dato: Archivo, que debe tener el nombre del archivo *.Rep que almacena el diseño, pues sin esto fallará la automatización del trabajo. Si el archivo *.Rep radica en el subdirectorio del programa, basta su nombre; si está en otro subdirectorio, requiere la trayectoria completa.


II.8.4.3 – Consulta

Presenta una tabla con la información de las Actividades


II.8.5 – Diseño Documentos

Estas funciones se emplean para diseñar la automatización de los trabajos de:

· Documento: Imprime un formato de Word

· Formato: Imprime los datos sobre un formato preimpreso

· Fax: Genera un documento en Word, para envío por Fax

· EMail: Envía un correo electrónico

· Telefonema: Para que un operador haga telefonemas

· Visita: Imprime una orden de visita

El sistema genera automáticamente diversos documentos usados en las actividades estándar, que en estas funciones son diseñados. Esta capacidad de permite ahorrar una gran cantidad de trabajo, ya que se usa cientos de veces.

Como recordará, al registrar un deudor nuevo o modificar el procedimiento aplicable a un deudor previamente existente, el sistema automáticamente genera acciones para ese deudor, con todas las actividades que están incluidas en el procedimiento; las actividades cuyo tipo es: documento, formato, fax, visita y correo electrónico. De tal forma que cuando llega el tiempo de realizar estas acciones, se generan los documentos para imprimirlos o enviarlos.

El documento consiste usualmente en un formato fijo, al que se insertan los datos elegidos en los lugares señalados. Una vez diseñado el formato fijo, con estas funciones se definen los datos que va insertar y el lugar donde serán insertados. Una vez grabado, para evitar que alguien lo modifique, puede señalarlo en el explorador de Windows, y con botón derecho ver sus propiedades, marcado Solo Lectura


II.8.5.1 Documentos

Inicialmente se diseña un documento en Word, con todo los elementos que requiera: logotipo, imágenes, texto fijo, cuadros, etc. y lo graba en el mismo subdirectorio donde radica el sistema (usualmente: C:\Archivos de programas\CobTra).

El primer paso es elegir que datos va a utilizar, y para ello se presentan listas con las tablas que contienen información de deudores, clientes, pagos, etc., para que elija la tabla de la que quiere tomar los datos.

A continuación se presentan los datos de la tabla elegida, para que señale los datos que desea, tocándolos. Al tocarlo cambia su color de fondo, indicando que esta elegido, y si vuelve a tocarlo quita el fondo especial, indicando que ya no está elegido. Las teclas inferiores aceptan o cancelan la selección.

Para que pueda usar información de toda la base de datos, y no solo una Tabla, se presenta a continuación las otras Tablas que están relacionadas con la antes elegida. En el ejemplo, inicio con la tabla Deudor, y esta puede relacionar información de otras tablas: Pagos que ha hecho el deudor, Comisiones originadas por el deudor, Cliente al que debe, Llamadas que se le han hecho, etc.

Si desea datos de estas tablas relacionadas, elija la deseada y se presentarán los datos de esa tabla, para que elija los deseados. Este ciclo se repite hasta que no hay tablas relacionadas ó el usuario indica que finaliza tocando la tecla [Esc] en la elección de tabla.

Para comprobar que los datos elegidos son correctos, se presenta una tabla con ellos que revisara. Cuando toca [Termina], se pregunta si son los datos deseados; si acepta continua el diseño; sino, se cancela

A continuación se carga Word, con un texto de instrucciones que le ayuda a diseñar el documento en Word y colocar los marcadores

Redacta el nuevo documento o abre el ya diseñado que vaya a usar. Para ubicar el lugar donde va cada dato elegido, se inserta un marcador en Word, con el nombre que te indica el programa (Para ver los marcadores en Word, usar: Herramientas-Opciones-Ver: Ver marcadores)

Para insertar un marcador en Word:

1 - El programa indica el dato a insertar. Cambia a Word para insertarlo.

2 - En Word, señala con el cursor el lugar donde va el dato

3 - Inserta el marcador, usando el menú: Insertar – Marcador.

4 - En Nombre del Marcador, copia el nombre del dato con teclas: Ctrl.-V (que el programa puso automáticamente) y toca tecla: Agrega.

5 - Regresa al programa, para tocar la tecla Acepta y tomar el siguiente dato

Finalmente, graba el archivo con un nombre diferente y descriptivo, que puede ser el mismo nombre de la Actividad, y anótalo pues el programa lo pide. Es mejor grabarlo en el mismo subdirectorio del programa. Al finalizar cierra Word.

Se pide localizar el archivo *.doc que grabó con el formato fijo, para que un archivo que almacena el diseño, que tiene el mismo nombre pero extensión *.Rep

El nombre de este archivo: *.Rep, lo necesita el campo: Archivo de la Actividad que lo usa, para que se pueda automatizar esos documentos.


II.8.5.2 Formatos

Frecuentemente son usados formatos preimpresos en muchos trámites, en los que deben escribirse los datos en lugares definidos. Inicialmente debe capturarse la imagen del formato por medio de un escáner, obteniendo un archivo de imagen en formato JPG, GIF o BMP. El escáner se configura para una resolución de 300 PPP (Puntos por pulgada – DPI en ingles) y una dimensión de la imagen de 800 pixeles de ancho y 1,100 pixeles de alto, para imprimir el documento a tamaño carta. (Si usa otros tamaños, tome como base estas dimensiones para calcular proporcionalmente el tamaño debido de la imagen)

Se pide localizar la imagen, que se recomienda este en el subdirectorio del programa.

El siguiente paso es definir los datos que se usarán, siguiendo el método del inciso anterior.

A continuación se elige el tipo de letra usado para imprimir los datos: Fuente, Estilo y tamaño

Se presenta a su derecha la lista de los datos que ha seleccionado, para elegir el que va a colocar. Si eligió un dato, se pide que indique con el cursor el lugar en que se escribe el dato, tocando la imagen del formato en ese lugar. Puede usar el mismo dato en varios lugares.

Cuando termine de colocar los datos, en vez de elegir un dato, finaliza con tecla [Esc].

Al terminar la colocación de los datos, se graba un archivo con el mismo nombre que el archivo de la imagen. Pero con extensión REP, que almacena el diseño realizado. Este archivo *.Rep se registra en el dato archivo de la actividad que utilizará este formato


II.8.5.3 EMail (Correo electrónico)

Para enviar correos electrónicos masivos, se escribe el texto fijo del correo electrónico en la ventana

A continuación se eligen los datos que desea insertar en este texto fijo, usando la tecla [elegir Datos]. La 1° vez que usa esta tecla, se presentan listas de las Tablas y sus datos, para que seleccione los datos usados, como se describe en inciso II.851. Posteriormente solo se presenta una lista de los datos seleccionados, para colocarlos dentro del texto fijo.

Para colocar un dato, elija en la lista con doble toque y a continuación toque el lugar deseado en el texto y péguelo (usar teclas: Ctr V)

Cuando termine de colocar los datos, use [Grabar y terminar] y se le pedirá el nombre del archivo que almacena el diseño, así como el Asunto ó título del email. Se graban 2 archivos con el mismo nombre y extensión diferente: *.Txt para el texto del EMail, y *.Rep para los datos usados. Este diseño podrá ser usado por las Actividades de tipo EMail, si su dato: Archivo contiene el nombre del archivo *.Rep


II.9 – REPORTES ESPECIALES

Todo el dinero y esfuerzo que dedica a los sistemas informáticos, tienen una sola razón: poder manejar su información como lo necesita. Estas funciones están hechas para que pueda obtener la información con libertad, sin restringirse a las funciones del sistema, sino diseñando sus propios reportes.


II.9.1 - Consulta de Tablas

Las demás funciones tienen objetivos específicos, y manejan los datos necesarios para esas funciones concretas; sin embargo frecuentemente se requiere revisar, modificado o eliminar en forma diferente a las funciones previstas, por lo que es necesario diseñar, en forma libre, la información necesaria. Esta función cubre dicha necesidad, permitiendo Consultar, Imprimir, Exportar y Modificar todos los Archivos.

Inicialmente selecciona el archivo que contiene los datos deseados, y se pregunta si desea todos los Datos de este archivo ó no.

Si la respuesta es no, se presenta una lista con todo los datos del archivo elegido para que elija los datos

Lo datos los elige tocándolos uno a uno, y al final toca [Aceptar].

Una vez definidos los datos, se procede a elegir el uso de ellos:

Panel: Presenta todos los datos de cada registro en la ventana de un panel, y puede seleccionarlos, ordenarlos ó imprimirlos.

Tabla: Presenta los datos de todos los registros en una tabla, y puede seleccionarlos, ordenarlos ó imprimirlos.

Archivo: Exporta los datos del archivo elegidos, en un formato de texto y tabulador, que puede importar en Excel, Word y muchos otros programas. Tendrá que escribir el nombre del archivo en que se exportan.

Cuando desea compartir la información que tiene en este Sistema con otras Aplicaciones, esta función le permite exportar la información en un formato usual para importarla en Bases de Datos, Hojas de Calculo electrónicas, Directorios de Palm, Outlook, etc.

Modifica: Permite modificar todos o algunos de los datos elegidos en forma masiva, es decir, cambiando su actual contenido por otro, igual para todos, que usted define. Resulta muy conveniente para cambiar muchos Registros en forma automática, aunque debe usarse con cuidado porque los cambios aceptados son irreversibles.

Para ello, una Tabla con todos los registros del archivo, presentando los datos que eligió, le permite seleccionar cuáles registros se modificarán. Use la tecla Selecciona y establezca las condiciones para escoger aquellos registros que desea modificar Ver {selecciona}

Al terminar, se pregunta si procede a elegir lo(s) dato(s) que se modificarán o cancela la modificación. Si opta por continuar, se pregunta en cada dato si desea modificarlo; y para cada dato modificado aparece al pie un campo en el que escribe el nuevo contenido de este dato, en todos los registros seleccionados del archivo.

Finalmente se confirma si desea realizar la modificación que ha programado: Acepta, ó se anula la operación, tocando la tecla Cancela

Elimina: Permite eliminar todos o algunos de los registros del archivo elegido, en forma automática,

Para ello, una Tabla con todos los registros del archivo, presentando los datos que eligió, le permite seleccionar cuáles registros se eliminarán. Establezca las condiciones para escoger los registros que borra.

Finalmente se confirma si desea eliminar los registros seleccionados


II.9.2 - Reportes Multitabla

Esta función es más poderosa que la consulta de tablas, que solo le permite usar datos de la tabla elegida, pues le permite obtener la información que necesita de múltiples tablas.


II.9.2.1 - Nuevo

Diseña un nuevo reporte especial. Para elegir los datos que va a utilizar se presenta una lista con todas las tablas que contienen su información, para que elija una, y a continuación le permite elegir las demás tablas.

A continuación se presentan los datos de la tabla elegida, para que señale los datos que desea, tocándolos. Al tocarlo cambia su color de fondo, indicando que esta elegido, y si vuelve a tocarlo quita el fondo especial, indicando que ya no está elegido. Las teclas inferiores aceptan o cancelan la selección.

Para que pueda usar información de toda la base de datos, y no solo una Tabla, se presenta a continuación las otras Tablas que están relacionadas con la antes elegida. En el ejemplo, inicio con una tabla: Deudor, y esta puede relacionar información de otras tablas: Pagos que ha hecho el deudor, Comisiones originadas por el deudor, Cliente al que debe, Llamadas que se le han hecho, etc.

Si desea datos de estas tablas relacionadas, elija la deseada y se presentarán los datos de esa tabla, para que elija los deseados. Este ciclo se repite hasta que no hay tablas relacionadas ó el usuario indica que finaliza tocándola tecla [Esc] en la elección de tabla.

Las relaciones entre tablas, que puede revisar en inciso {I.3}, le sirven para planear las tablas que puede relacionar, para que elija la inicial adecuadamente.

Para comprobar que los datos elegidos son correctos, se presenta una tabla con ellos que revisara. Cuando toca [Termina], se pregunta si son los datos deseados; si acepta continua el diseño; sino, se cancela


II.9.2.2 - Menú de Reportes

Para usar un Reporte especial multitabla que anteriormente diseño, esta función le presenta una lista de ellos, para que elija el deseado.

El reporte elegido se presenta en formato tabular, que puede seleccionar, ordenar, imprimir o exportar a Excel u otro programa.

Las teclas inferiores sirven para disponer de las siguientes opciones:

[Selecciona] | Le permite escoger aquellos registros que cumplan ciertas condiciones. {III.131}
[Ordena] | Para que pueda dar la secuencia deseada a los Registros {III.132}
[Imprime] | Imprime o exporta los datos de la Tabla, sean visibles ó no
[Termina] | Termina la revisión de datos y regresa al Menú


II.9.3 - Cubo de datos

¡Error! Vínculo no válido.
La información detallada de cada operación realizada en el sistema ha sido registrada en la base datos, y estos Reportes estadísticos le permiten utilizar esta información para conocer múltiples aspectos de la operación de su empresa, en forma resumida.

La importancia radica en que le ofrecen una radiografía de las operaciones, en reportes ejecutivos, con la información necesaria para dirigir, controlar y supervisar la empresa.

Así como los sentidos de su cuerpo le dan la información que necesita del mundo exterior, los reportes ejecutivos le dan la información que necesita conocer de las operaciones de la empresa para dirigirla, controlarla y supervisarla con la fuerza de los datos. Para describir su manejo, usamos como ejemplo la facturación de una empresa.

En el menú Reportes, se presenta inicialmente una lista de las áreas de Reportes, para que elija con doble toque de ratón sobre la fila correspondiente, o señalando la fila con las flechas y eligiendo con la tecla [Intro] A continuación se presentan los Reportes del área elegida, para seleccionar el deseado.

En la pantalla que presenta el título, descripción y Datos del reporte, que es en realidad una familia de Reportes que tienen en común los datos básicos, presentados en la pantalla en el campo: Datos. (Clientes.Empresa). En ésta pantalla puede elegir 5 parámetros para producir decenas de reportes diferentes, adecuados para diversas necesidades.

Para describir su manejo, se usa como ejemplo un sistema que registra las Facturas que diversos Clientes comisionan a la empresa para su cobranza, y el reporte emplea los registros de Facturas, Clientes y otros para obtener variados reportes sobre la Facturación.

Los parámetros que pueden programarse en la familia de reportes, tocando el campo respectivo, son:

· Clase

El usuario define la clase de reporte deseado, eligiendo entre:

· Estadística clasificada - presenta una tabla estadística cuyas filas corresponden al dato básico: Empresas clientes (Datos: Clientes.Empresa) y cuyas columnas presentan el subtotal del importe de las facturas (con Dato: Facturas.Importe) para cada empresa y concepto.

· Suma de concepto: presenta una tabla estadística cuyas filas corresponden al dato básico (Clientes. Empresa), seguidas del subtotal del importe de las facturas para cada empresa (Dato: Facturas.Importe)

· Detalle de registros: presenta los registros individuales con los datos básicos (clientes. Empresa) seguido del importe de la factura

· Hace

Aquí el usuario elige la operación de estadística que se hace, que puede ser la suma de los registros individuales, el valor promedio de estos por el conteo de la cantidad registros involucradas

· con Dato

El usuario elige el dato con el que se hacen las estadísticas, que debe ser un dato cuantitativo. En este caso, el importe de cada factura (Facturas.Importe).

· Clasifica

Se elige el dato con el que se clasifican los registros, para obtener subtotales por concepto, que es usado solamente en las estadísticas clasificadas. Puede usar cualquier dato, pero como le da una columna por cada contenido del dato diferente, se recomienda usar datos que tengan no más de 20 contenidos diferentes.

· Selectores

Permite seleccionar los registros trabajados, por ejemplo:restringir las facturas al mes vigente, o para solo operar sobre registros de un cliente en particular .

Al combinar las variaciones de estos 5 parámetros, puede obtener decenas de Reportes estadísticos diferentes a partir de ésta familia de reportes, por ejemplo: La facturación total de cada cliente por año, por mes de un año, por semana de un mes, cantidad de facturas con importe mayor a $5,000, atrasadas en cobro, etc.

Una precaución importante es elegir los datos usados en con Dato y Clasifica que sean coherentes, pues no todas las combinaciones son válidas. Si se usan datos de la misma tabla, no hay problema; pero si con Dato y Clasifica son de tablas diferentes debe cuidarse que la relación entre estas tablas sean uno-uno, o sea que a cada registro de la tabla con Dato le corresponde un registro de la tabla Clasifica. El problema surge si cada registro de la Tabla de con Dato tiene relación con varios registros de la tabla de Clasifica, pues la base de datos obtiene todos los registros que contengan los datos usados, y siendo varios los registros de Clasifica que corresponden a cada registro de con Dato, se duplican y dan resultados erróneos.

En estos casos, se da un aviso que los resultados pueden ser inválidos, y se pide que revise su validez. Para ello, con el mismo reporte, use Clase = Detalle para conocer la cantidad de registros que debería tener (el número entre paréntesis { }) y luego use Clase = Estadística Clasificada con Hace = Conteo ocurrencias; el número de registros en ambos casos debe coincidir para que sean válidos los resultados.

Las teclas inferiores le permiten:

· Ejecuta: Obtiene el reporte especificado, según los parámetros, presentándolo en una ventana tabular.

· Graba: Puede almacenar el diseño del reporte presentado, memorizando los parámetros que usó para producir un reporte específico en ésta familia de reportes, lo que es útil para los reportes de uso frecuente. Para ello, se pide escribir el área, que organiza en grupos los reportes, y se presentan el título y la descripción para que los adecue a su propósito. Posteriormente, aparecerán en el menú inicial de reporte, en el área asignada.

· Elimina: Si desea borrar el reporte presentado, puede hacerlo con ésta tecla, previa confirmación, pues la eliminación es definitiva.

· Termina: Regresa al menú inicial del sistema.


II.9.3.1 – Estadística Clasificada

Usaremos como primer ejemplo, la clase: estadística clasificada, que presenta, para cada cliente (dato básico), la suma (Hace = Suma de registros) del importe de las facturas (con Dato = Facturas.Importe), clasificada por Fecha.

Clasifica

Para elegir el dato clasificador, se toca con el ratón el campo delante de letrero Clasifica, y aparece una ventana que le presenta primeramente las dos tablas que contienen los datos de reporte: clientes y facturas. Al elegir una de ellas aparece a la derecha una lista de los campos que tiene la tabla elegida, para seleccionar al dato clasificador con doble toque de ratón.

Para el caso especial de fechas, muy útiles en los reportes, el sistema puede agruparlas por años, meses ó días, presentando en una columna los totales correspondientes a cada año, mes ó día.

Si el dato elegido es una fecha: Fecha_Fact, se pregunta si desea clasificar la fecha por [Año], [Mes], [Día], ó [Nada] (no desea clasificarlas). En este ejemplo se elige [Año], y entonces al reporte sumará en la columna correspondiente todas las facturas de ese año, del cliente que corresponde a la fila.

Para realizar los cálculos se toca la tecla [Ejecuta] y se presenta el siguiente cuadro estadístico.

Si se eligiera [Mes], habría tantas columnas como meses con facturas, y en cada una se pondrá la suma de las facturas de la empresa correspondiente a la fila y al mes de la columna. Debe tenerse en cuenta que esta clasificación no distingue los años, sino los meses, por lo que las facturas del mes de mayo de todo los años se suman; si desea solo un año, deberá usar el Selector para restringir las facturas presentadas al año en cuestión. Caso igual con el clasificador por Día.

Revise en el cuadro como los parámetros elegidos por el usuario configuran el reporte.

El dato básico de éste reporte es Empresa, por lo que es el primer dato en cada fila; hay una columna para cada año porque se eligió Estadística clasificada. Las facturas que no tienen definido el clasificador, la fecha en este caso, se colocan en una columna titulada con <>

El reporte se organiza de la siguiente manera: Se examinan todos los registros de facturas, agrupándolos por la empresa que los emitió, y se va sumando el importe de la factura a la columna que corresponde al año en que fue emitida, porque el parámetro con dato = Facturas.Importe y el parámetro Hace = Suma de Registros. En la fila de títulos, abajo de estos, se obtiene la suma de la columna (total de facturación en ese año, para todas las Empresas) y el la 2° columna, el total para cada fila (total de facturación para ésa Empresa, en todos los años).

Como en este ejemplo no se uso un selector, se trabaja con todos los registros de las facturas; pero que podría elegirse un selector para trabajar solamente con las facturas de un año o cualquier otro subconjunto, y entonces las cifras corresponderían a los registros de facturas que cumpla la condición del selector.

La tabla estadística le presenta las cifras absolutas, que puede imprimir {III.23} con la tecla [Imprime] pero es más cómodo observarlas en forma gráfica {III.41} disponiendo de ocho estilos de gráficas; puede imprimirse a color ó blanco y negro, copiarse al procesador de palabras o grabar la imagen en un archivo. Usando el estilo de barras de tres dimensiones, se obtiene la siguiente gráfica.

Selector

El reporte trabaja con todos los registros de la base de datos, lo que es adecuado en algunos casos, pero no en otros. El Selector le permite seleccionar la parte de ellos que le interesa para el reporte. En el ejemplo, para trabajar solamente con las facturas del año 2006, se usa el parámetro Selector. Al tocar el campo de éste parámetro se presenta una ventana que permite seleccionar los registros de facturas considerados para el reporte.

Esta presenta, en forma sucesiva, listas para seleccionar la tabla de donde tomará el datos selector, los datos que contiene esta tabla, para elegir el dato usado; el criterio usado para comparar y el comparador (escríbalo y termine con tecla [Intro], para indicar que termino de escribirlo).

Es este ejemplo, solo se consideran las facturas cuya dato Fecha_Fact tenga una fecha posterior al 31-Dic-2005. Si es la única condición, usa la tecla [Acepta]; si desea otra condición adicional usa la tecla [Continúa]. Una explicación detallada del manejo de ésta ventana, puede verla en {III.131}.


II.9.3.2 – Suma del Concepto

Otra clase de reporte que puede elegir es: Suma de concepto, la que presenta los datos básicos (en este caso: Empresa) en cada fila, y la última columna el cálculo elegido. En este ejemplo Hace = suma de registro y con Dato = Facturas.Importe, por lo que el cálculo elegido es sumar el importe de las Facturas. Esta clase de reporte no usa el Clasificador.

Se presenta una ventana tabular. En la cabeza de las columnas se presenta el título de cada columna y en las filas aparecen los datos básicos (Empresa). En la última columna, la suma del importe facturas para la empresa correspondiente a la fila, y en el título de la columna, la suma total; en el título de la tabla, entre paréntesis cuadrados, el número de filas (empresas) [16].

El reporte se organiza agrupando las facturas por la empresa que las emite y sumando el importe de todas las facturas de esa empresa; si se usara un selector, se podría restringir las facturas consideradas.

Usando una gráfica de dos dimensiones, cuyo manejo detallado puede ver en {III.41}, se presenta la gráfica.


II.9.3.3 - Detalle de Registros

La tercera clase de reporte que puede obtener es el Detalle de registros, que le presenta todos los registros considerados en el reporte. Puede usarlo para revisar a detalle y checar de donde vienen las cifras estadísticas.

Presenta los datos básicos (Empresa) seguido del importe de la factura (con Dato = Factura.Importe) para reportarle individualmente cada factura.

Puede ver de dos formas este reporte:

Total y Gráfica: Obtiene la suma del dato y puede graficarse, pero no seleccionar registros u ordenarlos.

Seleccionable: Puede ordenar y seleccionar los registros, para presentar e imprimir los que sean de su interés, pero no obtiene la suma del dato cuantificable (con Dato), ni grafica.


II.9.3.4 – Modifica la información

Los cuadros estadísticos presentados le dan una valiosa información resumida sobre las operaciones de la empresa, pero puede interesarle obtener información detallada. Para ello, con doble toque del ratón sobre una línea de la tabla, del caso que le interesa, puede seleccionar solo ese caso.

En el ejemplo, si toca la línea con Empresa Church & Dwight, aparecen las siguientes opciones:

Sin cambio: No hace ningún cambio, y mantiene inalterado el reporte.

Agrega concepto

Le permite agregar los datos que seleccione al reporte, para obtener mayor detalle en la información. En el ejemplo, puede agregar el Status de la Factura, que le dice el grado de avance en la cobranza. Para ello se abre una ventana para que elija el nuevo dato que se agrega; elija la tabla que tiene el dato y se presentan a elección los datos de esa tabla.

El dato elegido (Facturas.Status) se agrega a los existentes (Clientes.Empresa), mostrándolo en la pantalla de diseño y al ejecutar el reporte lo agregará.

El reporte original tenía una línea para cada Empresa; el nuevo reporte tendrá una línea para cada combinación de Empresa y Status, y las estadísticas ahora corresponden a cada combinación de Empresa y Status, con lo que obtiene información mas detallada que en el reporte original, obteniendo el total de facturación de cada Empresa según el Status de la factura.

Quita concepto

Elimina el nuevo dato agregado, volviendo al reporte original.

Detalle de fila

Si desea conocer la información detallada de una Empresa, con doble toque sobre la fila correspondiente agrega un Selector que restringe el reporte solo a las facturas que corresponden a esa fila. En el ejemplo, si toca la fila de la empresa Church con status Tramitar, se agrega al reporte un Selector para considerar solo las facturas que sean de esa empresa y status.

Puede usar los otros parámetros para obtener información detallada de esa empresa; por ejemplo, si agrega el dato Num_Factura obtiene las facturas individuales de esa empresa (también podría usar: Clase = Detalle de registros)

Elimina selección: Borra los selectores, para volver a presentar todas las empresas.


II.9.3.5 - Exportación

Además de imprimir el cuadro estadístico o la gráfica estadística, puede exportar el cuadro estadístico en un formato: texto + Tab, que puede leer Excel, o muchos otros programas: Notepad, Word, hoja de cálculo electrónica, base de datos, etc. eso tiene por objeto que utilice los Reportes en los diversos documentos que normalmente usa para comunicar a sus colaboradores, socios, etc. los hechos relevantes.

Cuando usa la tecla [Imprime] aparece un mensaje para confirmar la impresión [Si], exportar a un archivo el contenido del reporte, [No], o cancelar [Cancelar]
Si opta por exportar a un archivo el reporte, aparece una ventana que le permite escribir el nombre del archivo que será grabado, así como el subdirectorio en que será grabado